PXE Error "E53" No boot filename received

  • Hello there,

    Well i’m trying to set up a Fog server, release 0.32 on an Ubuntu Server 10.04 LTS machine.

    Im using a virtual machine on an Esx 4 cluster but I don’t think that my trouble is coming from there.

    The installation of Fog is working fine, I’m able to reach the web interface from a client on the network.

    I’m using 2 DC on 2003 Server, I correctly set up the DHCP option 66 with the Fog server ip address and 67 with the pxe image boot “pxelinux.0”

    I’m able to ping my fog server, i’m able to get the pxe file by using in a prompt the following command line :
    tftfp -i 192.168.x.x get pxelinux.0

    When trying to boot on lan with client I’m getting back the error message PXE-E53 : No boot filename received

    Any idea ?

  • This is a known issue with tftp-hpa service and Ubuntu 12.04.

  • Circling back here folks.
    From spiceworks post:
    This is kind of an old thread at this point, but I had the same issues so I wanted to put the information I found on here in the event it will help anybody else…what I found was that both DHCP, and TFTP had stopped working when I rebooted my 12.04 ubuntu LTS desktop. After doing some testing, here’s what I found that works for me to get it restarted quickly.

    1. Open a command window
    2. ENTER: sudo start isc-dhcp-server (enter your password when asked)
    3. ENTER: sudo restart tftpd-hpa


  • I have an unmodified router and have had no problems. I have a modified router (tomato) at home that is modified and I do the pxe passthru and also have no problems. I’m on Ubuntu 12.04 (notorious, I know) with the unmodified router and after a recent reboot (no updates) I get the PXE-E53 and PXE-M0F return on my clients. I did update (again) the tftpd-hpa entry and re-add my fog IP. Still nothing. Ugg.

  • I use a home-router that deals with my DHCP stuff. However, I use 3rd party firmware on my router. This firmware allows me to point at my tftp server as needed. So my setup is slightly different.

    That said, however, in the past, before building my own firmware for my routers or using 3rd party firmware, I just installed DHCP server on my FOG Server and all worked fine.

    If this isn’t working for you, though, you could try pointing a port forward for port 69 at your fog server. Just make sure to set your source as coming from your internal network so you don’t have Internet requests for port 69 being forward at your fog server. I believe it’s a UDP request, but for simplicity sake just choose both TCP and UDP for the port number.

  • I am getting this same issue but I really don’t see anyone address it with someone using this setup with a home router, that is already server DHCP requests. Any ideas there?

  • [SIZE=4][B]Problem Solved[/B][/SIZE]
    [B]PXE - E53 boot file not received[/B]

    While uploading the image from a system to Fog server my network switch is turned of by accident. Then restarting all the services I received “[B]PXE - E53 boot file not received” [/B]error from all the clients.

    I reinstalled the the Fog setup ( sudo ./installfog.sh ), then all is going fine.[B][/B]

  • Problem solve !

    My option in the Windows DHCP scope, 66 and 67 was not correctly applied, don’t ask me why…