SOLVED FOG Version 1.5.5 replicating over and over

  • Testers

    I am having issues with the server replicating to the remote nodes over and over again.

    [01-28-19 2:15:32 pm]  | Started sync for Snapin 11a - SimplifyPrinting - Resource id #21838
    [01-28-19 2:15:40 pm]   # 11a - SimplifyPrinting: File does not exist optfogsnapinsSimplifySuite.sfx.exe (11Storage)
    [01-28-19 2:15:40 pm]   # 11a - SimplifyPrinting: File does not exist on master node, deleting SimplifySuite.sfx.exe on 11Storage
    [01-28-19 2:15:53 pm]  | CMD: lftp -e 'set xfer:log 1; set xfer:log-file /opt/fog/log/fogsnapinrep.11a - SimplifyPrinting.transfer.11Storage.log;set ftp:list-options -a;set net:max-retries 10;set net:timeout 30; set net:limit-rate 0:128000; mirror -c --parallel=20 -R -i "SimplifySuite.sfx.exe" --ignore-time -vvv --exclude ".srvprivate" "/opt/fog/snapins" "/opt/fog/snapins"; exit' -u fog,[Protected]

    I notice that the snapin name is including the path without the / in its name. “optfogsnapinsSimplifySuite.sfx.exe”
    also its not adhering to the speed limits set.
    all nodes are on the same version 1.5.5
    I have to disable all replication on the server or it saturates our 100mb mpls connections
    Any help would be great.


  • Testers

    Thanks that worked!

  • Moderator

    @Greg-Plamondon This is known and was fixed last November just after 1.5.5 was released. Sorry I didn’t catch that one before the release.

    The fix is not a big one. See if you can add it to your current code manually or upgrade to dev-branch. Be aware, there have been many changes in dev-branch since then.