SOLVED capturing CentOS Linux image

  • How does centos image

    I adjusted the file system to ext4 to capture it but it started slowly after deployment and failed

  • Immediately before capturing CentOS 7.x I do the following.

    # Direct next Kernel recompilation to include AHCI drivers & be HW generic
    	sed -i 's|#add_drivers+="|add_drivers+="ahci|g' /etc/dracut.conf
    	sed -i 's|#hostonly="yes|hostonly="no|g' /etc/dracut.conf
    # Clean & Update the OS (includes Kernel recompilation)
    	yum clean all
    	yum makecache
    	yum update -y
    # Shutdown
    	shutdown now
  • Moderator

    @china-boy I might have just found what is causing the issue for you. Possibly the source is a standard IDE setup. Then usually dracut does not seem to add AHCI drivers. Before you capture the image to the following on the source system (as root user😞

    sed -i 's|#add_drivers+="|add_drivers+="ahci|g' /etc/dracut.conf
    sed -i 's|#hostonly="yes|hostonly="no|g' /etc/dracut.conf

    Then capture the image again and try a fresh deploy.

  • Moderator

    @china-boy Sorry for the long delay. Didn’t find the time to test this. I just did a quick test now. Installed CentOS 7 minimal - normal/ext4 partitioning, not LVM - captured that with Image Type “Single Disk - Multiple Partitions - Non-resizeable” and deployed to a fresh machine. Works fine.

    Let’s try to find out what I made differently to find the issue.

    • Source machine: VirtualBox VM, legacy BIOS, MBR/DOS partitoning
    • Destination machines: VirtualBox VM, legacy BIOS, MBR/DOS partitoning

    Is your source a virtual machine? What kind of? VirtualBox, VMware, …? Is it set to UEFI or legacy BIOS? Your destination is a physical machine, right? Is it set to UEFI or legacy BIOS?

    As well please boot the broken machine again. When you get to the dracut rescue shell run blkid and take a picture to post here.

  • @Sebastian-Roth I have tried to adjust the image type you mentioned, but the result is still the same. Could you please help me find the detailed document of Linux image production to capture? Thank you

  • Moderator

    @china-boy Sure people use FOG to deploy Linux! But every Linux is a bit different and might need adjustments as you have already see by changing the partitioning. Did you set Image Type to “Single Disk - Multiple Partitions - Non-resizeable” and re-capture the image (sorry forgot to mention this in my last post) before trying another deploy?

  • @Sebastian-Roth Hello, the question remains, hasn’t anyone used fogproject to deploy Linux

  • Moderator

    @china-boy Can you please try setting Image Type to “Single Disk - Multiple Partitions - Non-resizeable” for testing. Just to see if that works.

  • @jflippen said in How do I capture centos images:

    那么您可能必须重新创建初始CentOS 7安装,但不

    Hello, my problem now is that there was an error after the deployment of the physical machine