SOLVED Fog Server still using DHCP after I thought I removed everything

  • So I have attached a few images on what system looks like in configurations. I thought DHCP was stopped on this server but still having machines pick it up.

    I was told to do: Just set dodhcp to N inside of your /opt/fog/.fogsettings file and re-run the installer. From command line I can not get to those settings…must be doing something wrong. I can get /opt/fog but won’t let me into .fogsettings says not available. I thought I had done this and got into settings to change but I am not a ubuntu expert.

    I recently went through the setup as I updated to last fog release recently and image 1 will show DCHP is not running and instructions on how to make FOG work without DHCP server as FOG server.

    Image 2 is what I run to see if I can see DHCP entries.

    Any assistance would be appreciated. Thanks1_1542301470418_IMG_2.jpg 0_1542301470418_IMG 1.jpg

  • Moderator

    @bmick10 So now that you have it configured to not restart when the system is that’s good. Now just make sure the settings are correct in your .fogsettings file so that the dhcp server isn’t reenabled when you update FOG.

  • @george1421 Here is a picture of now. I also ran ps aux|grep dhcp in picture 2. Seems to be off now after I ran: So one question if I update will it enable these? Just want this to stop which I think it is and I restarted a few times and not seeing it running.1_1542317166506_IMG_2670.jpg 0_1542317166504_IMG_2669.jpg
    sudo systemctl disable isc-dhcp-server
    sudo systemctl stop isc-dhcp-server

  • Moderator

    @bmick10 Ok I see from the picture that isc-dhcp service is still running (hint: the very last line).

    So from the linux command prompt key in

    sudo systemctl disable isc-dhcp-server
    sudo systemctl stop isc-dhcp-server

    Now run the netstat command, that udp line should be gone.

    Understand this will turn off the dhcp server on the FOG server, if that was your intent.

  • 0_1542309228528_IMG_5.jpg @Wayne-Workman So think I found the issue the start and end range? Also can I leave the dhcpd as is? Anything else anyone see? Thanks![0_1542309195347_IMG_5.jpg](Uploading 96%)

  • @george1421 It is running I can tell. I think i found the issue. Will post to wayne’s comment but here is what it came back as. 0_1542308781761_IMG_3.jpg

  • Moderator

    Ok lets see if the dhcp server is still running. We can do this with two commands.

    #1 See if its listening. Post the output of this command.
    netstat -an|grep 67

    The output should have this line in it if the dhcp server is running

    udp        0      0    *

    #2 The next check is to see if the dhcp server is running in memory. Post the output of this line here and I’ll decode it.
    ps aux|grep dhcp

    Based on the output of the two above commands we’ll decide the next steps.

  • @bmick10 On the CLI, you must first become root:
    sudo -i

    Then, edit the fogsettings file with vim:
    vim /opt/fog/.fogsettings

    Set dodhcp to N, as you already know. Here’s the syntax:

    Here’s a tutorial on vi, which also applies to vim:
    Make sure you save your changes.

    Then re-run the fog installer.

    Here’s just a handful of commands to do things with the dhcp service directly…
    status: systemctl status dhcpd
    stop: systemctl stop dhcpd
    start: systemctl start dhcpd
    disable: systemctl disable dhcpd
    enable: systemctl enable dhcpd