Office Deployment Toolkit (2016) Snapin problem

  • New to this software and I’m blown away here. It’s really impressive what’s been done.

    I’m running 1.5.4 Fog Server on a Debian 8 OS. Hosted on VMware ESXi 6.5.

    Hoping for some help if anyone is able to take a look.

    I am attempting to install office 2016 using the Office deployment toolkit method.

    I have a share on a windows server that stores the office files which the client machines are able to access.

    The setup.exe file works with a /configure switch which points to an XML file for the settings that it will use to install office.

    Normally this can be accomplished using the following syntax in a batch file.

    setup.exe /configure configuration.xml

    The configuration.xml holds the path to the server where the office files are sitting. This just avoids each client from having to reach out to Microsoft for downloading the entire office installation file set.

    The XML file contains the following

        <Add OfficeClientEdition="32" Channel="Insiders" SourcePath="\\\snapin\Office2016" OfficeMgmtCOM="TRUE">
            <Product ID="O365ProPlusRetail">
                <Language ID="en-us"/>
        <Display Level="Full" AcceptEULA="TRUE"/>

    SourcePath="\\\snapin\Office2016" referes to the location on my server that is hosting the office files.

    I’ve created a batch file and zipped the three files (Configuration.xml, Setup.exe and Office2016Deploy.bat)

    The bat file looks like this

    "C:\Program Files (x86)\FOG\tmp\Office16\setup.exe" /configure "C:\Program Files (x86)\FOG\tmp\Office16\configuration.xml"

    Office16 is the name of the snapin I’ve created. Below is the settings I’ve been trying most recently.

    0_1537471759262_2018-09-20 15_26_18-Window.png

    The interesting thing to me is that if I extract the setup.exe and configuration.xml files and put tthem in an office16 folder in the tmp folder it installs office without issues. But when I assing this snapin as a task, I see the snapin folder appear for a second and then the task completes and the system prompts for a reboot instantly. It’s like the bat file isn’t getting a chance to run, or maybe it’s running only to fail immediately for some reason.

    forgive my ignorance. Hope someone is able to assist.


  • A little more information

    Below is a view of the C:\fog.log

    Not sure if I know what I’m looking for here, but I don’t think I’m seeing any errors

     9/20/2018 4:51 PM Client-Info Client Version: 0.11.16
     9/20/2018 4:51 PM Client-Info Client OS:      Windows
     9/20/2018 4:51 PM Client-Info Server Version: 1.5.4
     9/20/2018 4:51 PM Middleware::Response Success
     9/20/2018 4:51 PM SnapinClient Running snapin Office16
     9/20/2018 4:51 PM Middleware::Communication Download:||00:00:00:00:00:00:00:E0&taskid=49
     9/20/2018 4:51 PM SnapinClient C:\Program Files (x86)\FOG\tmp\
     9/20/2018 4:51 PM SnapinClient Processing SnapinPack
     9/20/2018 4:51 PM SnapinClient Extracting SnapinPack
     9/20/2018 4:51 PM Bus Emmiting message on channel: Notification
     9/20/2018 4:51 PM SnapinClient Starting snapin
     9/20/2018 4:51 PM SnapinClient Snapin finished
     9/20/2018 4:51 PM SnapinClient Return Code: 1
     9/20/2018 4:51 PM Bus Emmiting message on channel: Notification
     9/20/2018 4:51 PM Middleware::Communication URL:||00:00:00:00:00:00:00:E0&newService&json
     9/20/2018 4:51 PM Power Creating shutdown command in 60 seconds
     9/20/2018 4:51 PM Bus Emmiting message on channel: Power

    I also have been modifying my bat file and have added a output which works perfectly when I run it on my machine. I see the output file pop up and it has all the command responses.

    @echo off
    >C:\Temp\Office16.txt 2>&1 (
    PushD "C:\Program Files (x86)\FOG\tmp\Office16"
    setup.exe /configure configuration.xml

    However when I run this on my target machine nothing happens at all. I don’t see the output text at all.