• I am strugling with a Lenovo ThinkCentre M72e loaded with WIN 7. Using PXE boot it does not boot into the local disk. Anything else is OK.

    I can do all the menu items but “Boot to local disk”. It obviously prevents me from a lot of things but here is the details:

    Error message when using the FOG v 0.32 and this Lenovo as the client: “Booting from local disk…” and it freeses here.

    I have updated the BIOS to the latest release of 23.8.2012

    I have tried to use an older pxelinux.0 file but the message changes slightly:“Booting from local disk…
    PCE-M0F: Exiting PXE ROM.” and it also freeses.

    Turning PXE boot off and the PC boots just fine into the local disk and Windows boots up.
    Another brand of PC works just fine with PXE boot on the same network/FOG server.

    Any sugestions?

  • Just for information,
    I have updated Lenovo Thinkcentre 72 to the latest available BIOS : F1KT58AUS (dated 2013-11-28) and the problem remains :
    Can’t boot from HD if PXE has been selected first.

  • Senior Developer

    Also don’t be afraid to try local boot 0x80

  • Moderator

    You probably need a BIOS update to fix the pxelinux boot to “localboot 0”. Have you asked Lenevo about this issue?

    I found this page that looks interesting: [url]http://www.syslinux.org/wiki/index.php/Hardware_Compatibility[/url]

  • I am also having this issue, I have flashed bios to the newest, I have disabled UEFI, and have attempted the above fix by Greetz x23 and it still hangs at booting from local disk. When I did the modification above, it hangs at the Fog gui menu… Any more suggestions? I have 60 PC’s to deploy ASAP.

  • Hi,

    try this in your default file:

    [CODE]LABEL fog.local
    Boot from the local hard drive.
    If you are unsure, select this option.
    MENU LABEL Boot from hard disk
    KERNEL chain.c32
    APPEND hd0 0[/CODE]

    instead of:

    [CODE]LABEL fog.local
    localboot 0
    MENU LABEL Boot from hard disk
    Boot from the local hard drive.
    If you are unsure, select this option.

    It’s possible that you have to copy the chain.c32 from a syslinux archive to your tftp root folder, i integrated fog into an existing default menu, i use the above code to boot first hdd with my menu.

    Greetz X23

  • I had the same issue with Lenovo systems… What I did was go into the BIOS and disable UEFI. I selected “Legacy Mode” and it booted up just fine.

  • Guys,

    Latest update is that this is with the BIOS engineering team, who are working on the issue


  • Sure no problem

  • Paul - if/when you get any news from Lenovo, would you be so kind as to post it here? Thanks!:D

  • We have a ticket in with IBM (Lenovo) for this. They have replicated the problem, and are passing to the Product Engineering Group to propose a solution.

  • Making the changes outlined in the link above solved the booting to hard disk problem on my Lenovo E72 3493’s, and it looks a little cleaner coming out of the fog menu, too. The only problem is - if the fog server is down for any reason, these PC’s are dead in the water. The only real solution is for Lenovo to publish a BIOS that boots correctly.

  • I’ve got the same problem. Going to try chainloading when I get back to work on Monday. I will let you know what I find.


  • I have the same problem, if you found a solution or if anyone has one …