UNSOLVED A deployed image does not boot - No Windows Boot Manager

  • Hello,

    I’m having difficulties with deploying a Windows 10 IoT image. I’ve made an image on one PC and tried to deploy it on a different one.

    All the partitions and flags are the same, but I don’t get a bootable system on the deployed PC. In the BIOS there is no Windows Boot Manager as a boot option. The only way to fix this is booting Windows PE and execute the following commands:

    • bootrec /FixMbr
    • bootrec /FixBoot
    • bootrec /ScanOs
    • bootrec /RebuildBcd

    Deploying the same image on the source PC also don’t work (If I delete all the partitions first).

    What I’v tried:

    • Different image types: Single Disk - Resizable and Multiple Partition Image - Single Disk (Not Resizable)
    • Different Operation System: Windows 10 and Windows Other
    • Switched between BIOS and UEFI (reinstalled image)
    • Tried options Image manager Partclone Gzip and Partimage

    I’m using:

    • FOG 1.5.4
    • Ubuntu 16.04

  • Does somebody have any suggestions for me?

  • @george1421
    Thanks for your reply.

    The system is not sysprept and bitlocker is not enabled. But the PC is not even attempting to boot Windows because the BIOS doesn’t see the Windows Boot Manager.
    In the BIOS CMS is enabled and set to UEFI and legacy. Network and storage are set to legacy.
    I’ve installed installed Windows on the source PC with EUFI and legacy. Both have the same problem.

    The hardware is x64 (Intel Celeron N3160). A normal PC, so not an actual IoT device. Storage is on a m2 SSD.
    And mine mistake, it’s not Windows 10 IoT, but Windows 10 IoT LTBS. So it is actually Windows 10 Enterprise.

  • Moderator

    Are you sysprepping the golden image before image capture?
    Have you specifically disabled all bitlocker (yes there is a command for that and not via the gui) before image capture?
    What hardware are you attempting to deploy to (x86, x64, ARM)?
    Since its an IoT device, what is the storage device (NVMe, nand flash, etc.) ??