• I am testing the latest version of fog0.33 for use with intel atom based tablets. I am looking to compile a custom kernel but the versions i have tried never seem to be able to see the HDD.
    I have tried versions:
    3.3 - this worked with fog0.32

    Can anyone tell me which kernel version fog uses?

  • I have recently tried to image a virtual machine what was created under VMWare Workstation v9.0 on a Linux host. None of the available kernels worked and all reported that they could not find a hard disk.

    lspci -k in the VM shows that the SCSI controller is a:

    LSI Logic / Symbios Logic 53c1030 PIC-X Fusion-MPT Dual Ultra320 SCSI (rev 01)

    With a kernel module “mptspi” in use.

    I build a new kernel on another machine using:


    and this kernel works fine with the VMWare Workstation v9.0 VMs that use the LSI Logic SCSI disk controller option.

    Wondering what determines which SCSI controllers are chosen to be included in the FOG distribution kernels, and if just including all SCSI controllers would really make the kernel that much larger.

    As I look at the core.config, I see that almost all the SCSI controller low-level devices are included.

    I suspect that the Fusion MPT was simply missed because it is outside of the “SCSI device support” menu structure.

    Fusion MPT device support is actually at the same level in the menu as “SCSI device support” and is only 4 menu items down from it. Also, Fusion MPT device support does not mention SCSI in the help until you drill down to the SPI, FC and SAS options.

    Hope this helps to get Fusion MPT SPI support into an official kernel. 😉


  • Developer

  • Can someone with sourgeforce access upload a new custom kernel to the website. We are having trouble imaging Dell Optiplex 3010 and I think a kernel update is needed. The latest kernel on the website is 3.3.3 from 4-27-12…I think the latest linux kernel is 3.6.8

  • Cheers for the information.
    I have tried that config file today and it worked I will just have to experiment know to get rid of the drivers that aren’t needed to stop the various errors. But at least it can see the HDD’s after compiling a new bzImage file.

  • Moderator

    Use the core.config instead of the kitchensink one. There is also a way to get the current kernel config from /proc/config.gz somehow, but I don’t know the specific steps since the boot image doesn’t contain zcat.

  • Thanks for the pointer. unfortunately I tried that kernel with the kitchensink.config file from fog0.33 to form the bzImage file but it still didn’t work. For some reason it still does not see the hard drive. Went back to the original bzImage file and that can see the HDD.
    Any suggestions?

  • Moderator

    I think the FOG 0.33 uses a 3.3.3 kernel. And it gives those errors because it’s trying to load more drivers than are in your system to work on a wide variety of machine configurations. Ignore the errors or keep recompiling until you get really good at driver selection in the kernel config.

  • Thanks for the reply. I am still learning linux and fog setup.

    Do you know what kernel the bzImage file is based on as this is what i recompiled to work with 0.32 without problems. When trying to use this recompiled kernel with 0.33 it doesn’t see the HDD.

    The bzImage file that comes with version 0.33 can see the HDD without problem but throws up other errors that although dont effect the running are just annoying. The screen resolution is also finer than in 0.32.

    Thanks again for any advice / help

  • Moderator

    the client kernel has little to do with the FOG server kernel version. You are probably missing a step when including drivers during the kernel config steps.