• I am brand new to FOG so please excuse my lack of knowledge. I am in a position where I need to image a new HP ProBook 450 G5 and deploy to 20+ machines. The FOG server was already setup and running when I was hired. I am just trying to figure out how to use it. I can not get the laptop to boot to the FOG server. I connect the machine to the switch that is connected to the FOG server. I am network booting by holding F12. It takes me to HP boot menu screen but never to FOG host registration screen. I am sure I am doing many things wrong but I have searched for many many hours trying to figure this out and nothing I have tried seems to work. Any help would be great. This topic has already been solved somewhere so maybe just pointing me to that place would be helpful. Any and all advice is welcome. Thank you in advance for suggestions and answers.

  • @quazz @george1421 well, disabling secure boot seemed to do it. Thank you sooo much for the help. I will continue on with the process and hopefully all goes well.

  • Moderator

    @quazz Oops, sorry I didn’t see you jumped in here. I replied to the wrong person. Sorry.

  • Moderator

    @george1421 I don’t have this problem, F12 should just be “network boot” on HP.

    Maybe I got it wrong, but it sounded like he was just on the boot selection menu, before it even tries to load the ipxe binaries.

  • Moderator

    @quazz So when you plug in the network adapter, and press what ever key it takes to get into the boot manger. When you select ipv4 what happens next? This is where the picture would tell us what step it is on when it fails.

    If you plug a running windows laptop computer into the imaging network, does it pickup an IP address for the imaging network?

  • Moderator

    @akoleda OK if you are using the fog server, then that will narrow down what it can’t be.

    The fog server acting as a dhcp server will automatically adjust the boot file name base on the mode of the pxe booting computer. For example if the laptop is in bios (legacy) mode it requires one boot file name, while uefi mode take another boot file. You can’t boot a bios mode computer with a uefi based boot kernel.

    I can’t speak for the HP units, but on the Dells the boot menu is accessed via F12

  • Moderator

    @akoleda Strange, I could have sworn that on probooks, the boot menu key was F9.

    At any rate, just choose PXE through ipv4 or make it the first boot option in BIOS.

    edit: Good chance you’ll have to disable Secure Boot though

  • @george1421 The way it was explained to me is that FOG does indeed image to a dedicated network. The FOG server is acting as DHCP server.

    I am not sure that an error is occurring. When I try to boot into the FOG server to register host nothing happens. I see the HP boot menu with options to boot PXE through ipv4 or ipv6. My understanding is that it should just boot into FOG and that is not happening. Very possible that I am doing things incorrectly.

  • Moderator

    Since you are coming into this with little knowledge of FOG and your environment you may need to do a little research to how things are setup.

    Does fog image to a dedicated imaging network, or can you image a computer anywhere on your business network?

    PXE booting relies on having your dhcp server configured correctly. Now if FOG is on a dedicated imaging network, then the FOG server can act as a dhcp server. If the FOG server is on the business network, then your business dhcp server will be configured to support pxe booting.

    Once you understand what server is in control of your dhcp settings, then we can take the next steps.

    Also if you could post a clear picture of the exact spot the error occurs then we can have a bit more info on what’s not working.