• Posting here as a compatibility issue, as I only have this issue so far with the Lenovo.
    Lenovo X1 - using a docking station.
    PXE boot goes OK, sees server - but whenever I do anything like register a host, it goes into it’s process and hangs a couple lines in on init.gz

    I have left it and waited, no dice. Tried updating the kernel in the gui, no change.

    Manually registered a host, created an image, and created a capture task - same thing, stuck on init.gz

    Anyone have a work around or know what the hangup may be?

  • Server

    • FOG Version: 1.5.6
    • OS: Debian 9.9
    • Kernel: 4.19.48 TomElliott 64 and 4.19.48 TomElliott 32


    • Model: Lenovo X1 Carbon Gen6
    • Dock: Lenovo Dock USB-C DK1633
    • OS: Windows 10 Pro 64
    • Secure boot: disabled


    I’ve the same problem on Lenovo X1 Gen 6.
    As @george1421 suggested, I turned to FOS. Unfortunately I don’t understand the documentation to build an image.

    Thanks for your help.

    This works well with the adapter provided by Lenovo.

  • @sebastian-roth
    My eyes are failing me with age, it is indeed xz

    Unfortunately I’m out of time at the moment, unit has to get shipped out to fix faulty parts (not board related) - I will try again when it comes back from lenovo and let you know.

  • Senior Developer

    @aharris Still wondering about init.gz as mentioned by Tom this has not bee used for a long time. We have init.xz now.

  • Moderator

    Well maybe we can try a plan B to see if its pxe booting or FOS at fault here.

    I wrote a tutorial for creating a USB Boot drive to boot into FOS. There are some restrictions to going this route, but if you have a system with broken firmware then this is one path that we can use. Be sure to read through this document and pay attention to the caveats. https://forums.fogproject.org/topic/7727/building-usb-booting-fos-image

    I’ll IM you a few additional instructions look in the forum chat bubble for a few things to watch out for.

  • @george1421 No problem.

    Start PXE over ipv4
    Station IP address is x.x.x.x
    Server IP Address is x.x.x.x
    NBP Filename is ipxe.efi
    NBP Filesize is 1003408 bytes
    Downloading NBP File…

    Succeed to download NBP File.
    PXE Initializing devices…ok

    IPXE 1.0.0+
    Features - (lists)
    Waiting for link up on net0… Down
    Configuring net1 (mac)…ok
    Recieved DHCP answer on interface net1

    Then it stops, just stays there.
    Why does the wonky stuff always happen with C level users machines? 🙂

  • @tom-elliott I show that my fog version is up to date, version 1.5.4

  • Moderator

    Can we get a clear picture of where its hanging in the process?

  • Senior Developer

    @aharris What version of FOG are you using? init.gz hasn’t been used since 0.32, we’re now at 1.5.4 (with 1.5.5 around the corner).

  • @george1421 Thanks for the response. I updated firmware this morning and tried again, same.
    Sees server, starts it’s process, gets to init.gz… ok and hangs.

  • Moderator

    Make sure you have the latest firmware on the X1. These systems have been historically an issue. We have seen issues with faulty uefi firmware causing the system to hang during the booting of the FOS engine.

    FWIW bzImage (the kernel) and init.xz (the virtual hard drive) work together to make a complete system. My bet is that the kernel is halting on booting. A clear picture of the hang might give us other clues.

    As a sidebar, if you have FOG 1.5.4, please downgrade your FOS kernels to 4.15.2 to address a slow disk structure creation that was discovered after FOG 1.5.4 was released.