UNSOLVED Error message is mount: mounting on /images failed: Connection timed out

  • There is a problem mounting the FOG server /images directory on the PC client. We have followed the instructions in the Fog Wiki regarding Troubleshoot NFS but so far to no solution.
    We have created a debug task and have the client up and running with a basic linux kernel and are able to ping the Fog server. The client and server are on the same subnet. The nfs server and rpcbind have both been restarted and the /etc/exports file updated to reflect the recommendation in this troubleshoot guide. The .mntcheck file exists (in both /images and /images/dev on the Fog server).
    A tcpdump packet capture sees traffic both ways between the server and the PC client (although no idea what it says) when a mount command is given on the client using the debug console. “mount /images” (with the recommended switches) but nothing happens on the client until a time out.
    Running out of ideas as to how to find the reason for this error. All help appreciated.

  • Moderator

    @dj FOS (name for the FOG system that loads at that point) doesn’t need /sbin/mount.nfs

    I just checked and tested and it all works fine in my environment.

    Can you run mount -v | grep images on a system where you were able to mount the nfs share and take a screenshot/paste it here?

    What Ubuntu version is the FOG server running btw?

    Did you test the mount in FOS on a system that mount does work in a full linux distro?

  • @quazz Apologies for not forwarding the netstat results but I would have to manually copy them from one machine (CLI) to another. All looked OK with rpc and nfs running.
    I have been following the Fog NFS Troubleshoot guide and not having any luck with mounting a PC client after having it download the Fog debug program from the Fog server. I then tried to do a mount of the Fog /images and /images/dev directories using another Linux box. SUCCESS, at least to mount and copy a file from /images to /images/dev on the Fog server. I then tried the same exercise using a Mac and successfully mounted it to the Fog Server.
    Along this process (had to install nfs-common on the Linux client) it was drawn to my attention that /sbin/mount.nfs should exist on the client. This made me check the Fog Debug CLI on the PC client and such a file does not exist suggesting to me that I cannot use the Fog Debug CLI to mount a NFS directory on the Fog server. Anyway, testing mount: successfully with Linux and MacOS says to me that the Fog Server is working properly to some extent. BUT…
    Setting up the Fog server to upload an image from the PC-client still does not work resulting in failing to mount the /images/dev folder. Here is (in part) what is displayed on the PC-client.
    Send method … NFS
    Checking in … Done
    Mounting File System …

    mount: mounting failed {FogServer IP}:/images/dev on /images failed: Connection timed out.
    * Preparing to send image file to server.
    * Checking Mounted File System
    * An error has been detected!!
    Fatal Error: Failed to mount NFS Volume

    Computer then reboots after 1 minute.

    This appears to be a FOG problem with getting PC clients to successfully mount the NFS Volumes (/images and /images/dev) but at this stage of the process FOG is ‘controlling’ everything and I’m at a loss how to proceed from here. I can successfully mount volumes using Linux and MacOS but Fog client won’t. Frustrating.

    All suggestions on debugging this issue greatly appreciated.

  • Moderator

    @dj What do you see on the FOG Server when you run netstat -ulp

  • @quazz Selinux is not installed (default Ubuntu16.04 in KVM VM) and although there is a firewall running on the Host, packets are not routed through the Host. The FOG VM is on the same subnet as the PC client and packets are routed through a NIC in Bridge mode straight to the FOG VM which isn’t running a firewall either.
    I can see a number of packets being exchanged (tcpdump) between the VM and the PC client using Port 111 (sunrpc / nfs) so I assume that NFS is working to some extent but the client always times out trying to mount the remote drive on the Fog server. Thanks.

  • Moderator

    @dj What is the host OS?

    Maybe there’s a firewall/SELinux on the host?

  • @george1421 Thanks for your help, much appreciated. And apologies for the ‘slowness’ of this conversation as I am volunteering at a school and only get to look at FOG problems on a Friday.
    The command showmount -e localhost returns
    Export list for localhost:
    /images/dev *
    /images *

    The Fog server is a VM running Ubuntu and selinux is not installed. FW is open, so no access problems that I am aware of.

  • Moderator

    Is both the linux firewall disabled and selinux set to permissive on the fog server?

    What is the output of this command executed on the fog server showmount -e