Booting from Acronis 2010 iso over network using FOG

  • Has anyone managed to do this? I’ve seen examples of people with Acronis in their boot menu, but they haven’t explained how they’ve done it or what version they’re using. I’ve added:

    LABEL Acronis
    kernel fog/acronis/memdisk
    append iso initrd=fog/acronis/acronis.iso
    MENU LABEL Acronis
    Run Acronis True Image 2010

    But I get the program locking up either on first load, when first entering the GUI or when loaded the GUI but “Processing”.


    EDIT: This does actually work, my issue was that I tried it on (1) a machine that won’t boot off the acronis CD either (2) a machine that randomly turns itself off and (3) a machine without a hard drive - the last one is important, it seems Acronis doesn’t like to run without a hard drive, somewhat understandably.
    I’m still trying to run from the extracted kernel and ramdisk images, though, because they’re half the size, and will make boot times practical even on a 100mbps network.

  • OK, I’m an idiot, I’d somehow overwritten the ramdisk image with the kernel, turning off quiet produced an error that made that clear (unreadable ramdisk image, essentially).

    Now I can load the kernel, but I eventually just end up at a command prompt. If I type “acronis” there, it does some stuff (something with network interfaces then enumerating my drives) but then just dumps me back to the prompt. Do I need to run it from a graphical environment? Is there any way to automate whatever the solution to getting it to run is?

  • The error specifically is (with quiet off):

    No filesystem could mount root, tried: romfs
    Kernel Panic: Syncing VFS: Unable to mount root fs on unknown block (1,0)

  • I’ve also tried using the .dat files from the ISO like this:

    [COLOR=#000000]KERNEL kernel.dat
    APPEND initrd=ramdisk.dat ramdisk_size=64000 quiet vga=0x315[/COLOR]
    [COLOR=#000000] [/COLOR]
    [COLOR=#000000]Acronis starts to boot, but instantly gives a kernel panic saying it can’t access storage.[/COLOR]