Network Boot Problems/Computer won't communicate with Ubuntu/FOG

  • I was hoping to see your dhcpd.conf file on your dhcp server. When you say you had no luck I take it then that you mean you couldn’t get onto it to alter the config? I thought perhaps you meant that you had tried unsuccessfully to modify it.

    Have you used Wireshark before? Great tool for finding out whats going on at the heart of a network. I think it’d come in real handy for you in dealing with this issue too. Give it a go. If you’ve never used it before it can seem very complicated and overwhelming, but its quite straight forward for beginner use anyhow. Install it, run it, and select your chosen interface to watch on near the top left. Once you’ve done that it will immediately start live capture of packets.

    What I suggest you do is run this on a machine on your network to observe what is happening, and while its running, try to boot another PC from the network. Watch for packets of the DHCP variety. You’ll see them come up under the DHCP Protocol, and in the INFO field next to it will be “DHCP Request” followed by a couple of “DHCP Discover” entries. Click on the discover line(s) and take a closer look in the main information window below the list (bottom half of the screen). Somewhere down there will be an entry that says “Bootp flags” and within that will be the line “Next Server IP address”. If there is nothing there but “ (” then your dhcp server is not giving out bootp addresses which is what gives a network booting machine the ability to talk to fog’s tftp server.

    In short if you only get there then your good to go and can use the dhcp proxying method of supplying the extra details. If it does pick up an address, you really need to get in touch with the people who maintain the system giving out the addresses and explain your situation because if its giving bootp addressing out, its not directing you where you need to go, and you cant change it.

    Hope I haven’t confused you too much 😉

    I’m sure there’s easier ways to say what I’m trying to get accross and perhaps if you are still in need of help with this, someone can convey in a more human friendly way the essence of what I am trying to get across. 🙂

    Oh incidentally the URL for the wireshark download is:


  • What is the best way to show you how I have it set-up?

  • Can you post your configs here? I’m not saying I’ll be able to help as I dont use a DHCP Proxy myself, I have full control over my DHCP setup so I’ve no need of one, but there are plenty of people on this forum with loads of experience that may spot the problem straight away.

  • OK…I was frustrated so I reinstalled FOG on my computer…tried everything again with no luck. We attempted to make changes to our DHCP device with no luck also.

    So…does someone want to take control of my computer and see what I have wrong? Help me please!!!


  • Time for a dhcp proxy. I’m going to take a wild stab in the dark here and assume you are running FOG on Ubuntu. If not, the info will still be handy at least.

    Try this: [url][/url]

  • Well, the CIPA fiter does not allow us to make any sort of changes. Now what???

    We looked and looked and it did not let us do anything


  • Well if you already have a device doing DHCP you could cause a “race” situation were they are both trying to hand out address. The proxy DHCP setup would allow FOG to hand out the PXE boot options to computers without messing with the DHCP device that is doing it now. Does someone else manage the device handing out addresses? If so ask they to add the boot options to the DHCP scope. IF not then proxy is the way to go.

  • Would it be easier if I made my FOG server give out IP addresses like a DHCP server rather than messing with our actual DHCP server?


  • You don’t have to add them to your FOG server, you add them to your DHCP options so your machines know where to look to PXE boot from and the file to use. Or you can do the proxydhcp option that chad-bsid said. This is the link for setting up a proxydhcp [url][/url]


    How do I add those files to my FOG server??

    You people are a huge help

  • I have no idea what OS is on the CIPA Filter and sniffing around on the web makes it seem to me that it’s a linux based proprietary OS.

    If you can get to a dhcpd.conf file on it the options you would be looking for would be as follows:

    filename “pxelinux.0”;

    Note the filename end of .0 is a zero.

    If you find you can’t get to it then you could use proxydhcp as chad-bisd suggested… which you can run from your fog server.

  • Moderator

    Bonk him on the head or get a new administrator?

    You can only have one DHCP server in a subnet, otherwise they enter a race condition to see who answers first, and you can get IP address lease overlaps. So FOG cannot be the DHCP server if any other device is doing DHCP.

    If you cannot, or will not modify your existing DHCP server to give out the required PXE boot options, then you can implement ProxyDHCP. ProxyDHCP does not give addresses, but listens for DHCP requests that need PXE boot information and responds with the necessary data, without interfering with your existing DHCP server.

  • OK. I will let Administrator know. Thanks for the help

    If he says that’s not the problem, then what??

  • Moderator

    [QUOTE] Get them to add the dhcp options for next-server and boot filename.[/QUOTE]

  • Our Network Administrator.

    What do we have to change in the CIPA Filter to get it to work?

  • Moderator

    Who manages that device? Get the to add the dhcp options for next-server and boot filename.

  • I think it is our CipaFilter(so the students don’t go on naughty sites). And it does support DHCP every computer in the school has a DHCP address with the exception of the teacher computers, they are unblocked

  • Moderator

    I agree with djm79. Find out what that device is and if it supports dhcp options for next server and boot file name. If the device doesn’t support the options or you just can’t change its configuration, there is always proxydhcp.

  • What device is I would think it was your router as its your default gateway too. You need to configure the DHCP scope with the boot server IP and the pxelinux.0 file to get them to PXE boot.

  • Here we go