PXE Backgrounds 404 not found.

  • This is a duplicate issue as others have had but due to previous threads being closed (some without answers).

    1. Copied bg.png into photo shop and changed a few things. Created a copy, gave it a name bg2.png file size is smaller than the original.

    2. Uploaded the file to /var/www/fog/service/ipxe as bg2.png

    3. Changed the owners to www-data:www-data permissions set to 644 (like all the others)

    4. Tried to browse to the file using http://serveraddress/fog/service/ipxe/bg2.png (does not work)

    5. Following step 4 with bg.png does work.

    Leads me to believe these are not in the path, or that Apache doesn’t like the file for some reason.

    Apache logs just say that there is a 404 file not found, but as I have stated the file is there. What could be causing this?

  • This ticket can be marked as solved. Just need to make sure documentation for RC10 is up to date as there is a problem with the link.

  • Ah… ok checked that path HTML/fog/service/ipxe and bingo… the files do not exist.
    Copied the files and boom they work.

  • Moderator

    @sourceminer can you confirm that bg2.png exists in the path I provided? As well as direct copying bg.png to pg3.png in the exact path I provided. There is/was an issue with ubuntu where there was two data paths for fog /var/www/html/fog/service/ipxe and /var/www/fog/service/ipxe

  • Thanks @george1421 for the response. The Log does not provide any clue.
    [12/Jan/2018:15:14:41 -0800] “GET /fog/service/ipxe/bg2.png HTTP/1.1” 404 525 “-”

    I did not think of renaming the existing bg.png to bg3.png, however in just testing this it did not work. Same error.

  • Moderator

    Repost from the other thread:

    @sourceminer Does the apache error log provide any clue?

    You have the right url path and if the permissions are set correctly it “should” work.

    If you were to go into the /var/www/html/fog/service/ipxe (watch the path, because there should be a ln directory in there) and copy bg.png bg3.png does it load.

Log in to reply