SOLVED "No valid data" image, but there is data in storage. How re-enable it?

  • Hi,

    I see some images that are assigned as “no valid data”

    besides there is data in its folder:

    $ ls /images/LenovoA70zPainelW10au/ -l
    total 17498324
    -rwxrwxrwx 1 fog fog         512 Mar 22  2017 d1.mbr
    -rwxrwxrwx 1 fog fog 17658470157 Mar 22  2017 d1p1.img
    -rwxrwxrwx 1 fog fog   259800100 Mar 22  2017 d1p2.img

    but “d1.partitions” file is missing. Is it the cause for invalidate this image?
    Is there a tool or some way to rebuild this file so recover this image?

  • Moderator

    @NateCCC Do you have any custom scripts, post-init or post-deploy?

    To me it seems you have a similar but still different issue. Better open a new thread and describe your setup in detail: FOG version, picture of any messages on screen at the end of deploy on the client, even better take a video of pre and post imaging screens…

  • I have experience the “No Valid Data” after successfully capturing an image. This has happened on 4 image builds in the past week. Is there a way to recover the image and make it valid? After the capture I see the image size is listed, although after trying to deploy the image the image size goes to 0.00gib. Any assistance on this would be great.

  • @wayne-workman and @sebastian-roth, this issue is solved. I thought I posted an answer days ago, but where is it? The important is FOG is running fine about this issue. When I reinstalled FOG, I unmounted images partition, so post init sripts were copied to original /images folder on server sda disk. So I unmounted /images againd e copied this folder to correct place.

    As the original question, it’s fine. I got successful to deploy this image to another host.


  • Moderator

    @Redbob In The screenshot you posted there is no critical error! The messages “error creating epoll fd” and “Deprecated option UsePriv…” are not an issue at all. What do you see after the “Running post init scripts…”?

  • @redbob Do you have any post-init scripts?

  • @wayne-workman , I think it’s another issue. I cannot deploy any other image, because I got this error below. The deployer stuck in this screen, no regarding what user I choose to execute the task:

  • @redbob Does the image deploy OK? The field you are referring to is called ‘Captured’ and that’s just a datetime in the DB, and shouldn’t have any impact on functionality.