boot into windows failure after deployed image

  • I have my images setup in a VM. They have been captured in FOG. The images are all windows 7. I tries to deploy to an Optiplex 7020. And after deploying during startup I received the following error message :


  • @wayne-workman

    Yes I did not activate the sysprep application. Once I activated it and recaptured the image. The problem was resolved.

  • @bc601 said in boot into windows failure after deployed image:

    I did not sysprep the image correctly went back and syspreped the PC used for the image and tried it again. This time it worked after redeploying the image

    Do you know what you did wrong? What did you do differently?

  • @george1421

    Okay found out what the issue was. I did not sysprep the image correctly went back and syspreped the PC used for the image and tried it again. This time it worked after redeploying the image

  • @george1421

    I have no idea were they came from.

    So how do I correct the setup error ?

  • Moderator

    @bc601 in there you have setupact == setup activity log. and setup error logn. Where did you get those files from>

    I haven’t figured this out quite yet. But I’ve found these files in c:\windows\panther and c:\windows\setup\sysprep sometimes. You probably should see both places. Also I suspect the setup error [setuperr.log] to contain the reason why your OOBE failed. Sorry I can’t be more specific its been about 6 months since I last debugged a deployment.

  • @george1421

    Ok it was a success. I now have the log files. I noticed something weird the setup.log file is empty and spelled incorrectly


  • Moderator

    @bc601 Did you create a capture or deploy task. Only a capture task will allow you to write to images (/images/dev on fog server).

  • @george1421


    On the last step. Step 10. I received an error message stating the following
    This error repeated for each .log file. I also included the screenshot of the rights to the /images folder.

  • Moderator

    @bc601 Ok then run this command just before the mount.

    mkdir /ntfs

  • @george1421

    I Received the following error on step 8 : ntfs-3g mount: failed to access mount point /ntfs: no such file or directory

  • Moderator

    @bc601 The instructions are not easy, but they are not hard either.

    1. On the computer that has failed. Reschedule a FOG capture task but enable debug mode.
    2. PXE boot the target computer
    3. After a few enter key presses you will be dropped to a linux command prompt on the target computer.
    4. key in fog to start the capture process (no worries we are going to jump out before anything is captured)
    5. Press enter until you are after the step of Mounting file system (press enter)
    6. When you see the step Checking mounted file system press Ctrl-C. This will drop you out to a linux command prompt again.
    7. Key in df -h you should see a line that says /images on the FOS client is connected to /images/dev on the fog server. (you need this step to have a place to move the log files to.
    8. Now you need to connect to the target computer’s hard drive. I find this command works most of the time ntfs-3g -o force,rw /dev/sda2 /ntfs This command will connect the 😄 drive of the target computer to the /ntfs on FOS.
    9. Now navigate to the Panther directory using this command cd /ntfs/Windows/Panther
    10. You can either look at those files there with vi or copy them to the FOG server so you can download them with WinSCP to review them in windows. The log files all end with .log extension.
    11. If you want to copy them to the fog server this command may get you close. cp /ntfs/Windows/Panther/*.log /image Then on the fog server you can pick up those log files in the /images/dev directory.

    I’ll tell you its much easier to just get a Y power cable for sata like this one and review the log files on a second computer. But the above way will work. I’ve done it several times with the steps outlined above.

  • @george1421

    What are the instructions for getting to the logs in debug mode from FOG ?

  • Moderator

    @bc601 It doesn’t have to be another 7020. Any computer that has windows on it will work. But its true I didn’t consider only having one drive power cable. I do have a Y power cable in our build up room, so whenever I run into a single drive power plug we just insert the power Y cable.

  • @george1421

    Unfortunately there is only one power option for the HDD in this case so I dont have the ability to plug in the second HDD without unplugging the main one

  • Moderator

    @bc601 Ok if the system was sysprep’d then there are log files on the target drive as long as OOBE starts to install. The log files are in one of two places depending on where you placed the unattend.xml file.

    The first place is c:\windows\panther and the other is c:Windows\System32\Sysprep There are files in there with .log in the name (I think). Also there is a directory in the paths above with GC in the name (sorry doing all from a foggy memory). Anyway OOBE will write what its doing and where it fails into those log files.

    You can get to the logs in debug mode from fog, but its typically just easier to pop the hard drive out of the computer that failed and add it as a second hard drive in a working computer. Then access that broken install that way.

    Also when you are looking at the broken install drive, you can check to see if the required drivers are in the location you need them.

  • @george1421


    1: The system drivers for the 7020 are pulled from the FOG server during the image process. I cant get into the system to verify if the drivers successfully went into the 😄 drive or not
    2: Yes the image was syspreped

  • Moderator

    Two things.

    1. Are the system drivers on the 😄 drive of the 7020 when it boots?
    2. Did you sysprep the image?