SOLVED deploying "Other OS (99)" fails

  • I’m using fog 1.4.4 to deploy osx + windows bootcamp and catched some bug (and solution). I’m going to open one ticket each one.
    Second one.
    If you create an image with os type 99 “Other OS”, it can’t be restored because of:

    No source file passed (writeImage)
    Args passed:   /dev/sda1

    Digging, I found that there is no “99” case entry in restorePartition(). I modified it in:


    And it works.

  • @tom-elliott Thanks for your attention on my tickets!
    The most cryptic one (count= issue) is not solved by sgdisk -z before dd but after. I’m going to add some infos.
    Thanks again for FOG: I’ve been using it by 6-7 years. I can multicast deploy a 20 dual boot pc classroom in 30 minutes!

  • Init’s are updated with the latest code changes for this, and your other thread about the count= issue. I didn’t follow your instructions word for word, but i do have the sgdisk -z directly before the dd statement occurs.

  • With the automation of detecting volumes that can be resized, I think this is a non-issue and I’ve added the 99 check to the case statement.

  • Because, in my mind, in a multiboot environment (osx + windows), if I select osx (for example) it could not fit the windows os or reverse. I selected “99” os type to image a windows+linux for years, but let me know if it is better to choose an other option.
    Thanks for fog!

  • Senior Developer

    @Enrico Thanks for your message and the details? Why not set OS type to Windows or Mac OS X?