UNSOLVED Image of Hyper-V VM Stops (Rate Decreases)

  • FOG Details:
    Running Version 1.5.0-RC-8
    SVN Revision: 6080

    Hi all,
    I have a problem at the moment where I’m trying to image a Hyper-V VM, and it gets to about 40/45% and then suddenly the rate of the network connection starts going down, with no percentage increase at all. I’ve checked the FOG server itself and it reports it’s not sending out any packets (this is looking at the home page graph).
    I’ve tried this numerous times and keep running into the same thing. There are no network connection issues in our network at the moment aside from this.
    Has anyone else experienced a similar issue? What would be the recommended way of diagnosing this?

    Any help would be greatly appreciated as usual 🙂

  • @jdd49 The image seems to have worked now after rebooting the Hypervisor this morning, though I’m now getting the following error message when trying to boot the VM:


    I’ve recreated the VHD on a different Hypervisor and still run into the same issue. Annoyingly (but also thankfully), the actual physical machine I’m trying to virtaulise runs perfectly fine and doesn’t have this issue.

  • @sebastian-roth

    Below are the results for running smartctl -a /dev/sda:


    You can also see what kernel I’m using on the FOG server in that screenshot.

    The /images directory is on the one drive, so that’s probably why I couldn’t couldn’t unmount the device.
    Hyper-V is currently running on a Dell Windows Server 2012 R2 server with the latest updates.

  • I’m fairly certain this a kernel issue. What are you running hyper v on? Latest windows 10 build, server 2016? I ran into this with the latest hyper v, not with fog, but same principals apply. Using the 4.13 series 64bit resolved the issue for me. What kernel are you using?

  • Senior Developer

    @RobTitian16 Sounds kind of strange though I can’t figure if it’s a disk error or something you do. Can you simply run smartctl -a /dev/sda?

    About fsck… Do you have your /images directory on a separate physical drive? If not I can understand why it wouldn’t let you umount the device. Please post the full commands you used and the output produced so we can get an idea of what’s up.

    On the other hand I have to say that we are still not absolutely sure this is a disk issue. Just to keep that in the back of our minds. It’s just an assumption from what we’ve seen/heard so far.

  • @sebastian-roth Thanks!
    How do I go about using smartctl?
    It complains it can’t detect the device type, and when selecting the -d option, I get a load of options. I’ve tried setting this to -ata and scsi, but these all come back saying there is no such device.
    I have also tried running fsck after unmounting the drive, but then that complains the drive is still mounted (it isn’t… it’s clearly lying or being stupid), and says that continuing will destroy data, etc.

  • Senior Developer

    @RobTitian16 From what you say it sounds as Wayne is pointing the right direction as you say that this seems to happen at the same spot. On the other hand it could also be a disk issue on the Hyper-V server. Run SMART-tests on both I suggest. For Windows I’d suggest a tool called CrystalDiskInfo and on Linux just use smartctl.

  • @robtitian16 Is the disk running out of space? What kind of disk is in it? It could be that the FOG Server’s HDD has some bad sectors in the spot where it fails, and it is repeatedly trying to read them but can’t.