• Hello,
    We have a server on Ubuntu 10.10 Fog v0.30 which manages about 2,000 jobs and our new PC will be installed in Windows 7 64 bits.
    After several research and testing, we can not clone Windows 7 properly …
    Can you help me please?
    Thank you in advance.

  • Developer

    Please follow this guide on trouble shooting an image upload.


    The screenshot looks like it’s failing on the ‘ntfsresize’ command. This is where it will probably error or break.

    Generally if the NTFS resize fails, there is some sort of file system issue that has to be fixed with chkdsk.

    Any errors, or anything odd should be reported here.

  • This is the result:
    I prepared and run Windows FOGPrep.exe then three commands that are doing well.
    I ran the sysprep and tried to back up the image.
    The upload does not go away -> see image attached


  • Developer

    [quote=“CamC, post: 64, member: 34”]Even if using the “Single Partition (NTFS Only, Resizable)”?[/quote]

    Everyone should be running [B]chkdsk /f[/B] on all of their drives before preping the image.

  • Developer

    it looks like the problem is the 1st partition it must be 100mb. your 1st partition is 329301 * 512 /1024/1024 = 160.7mb

    FOG does not care 32bit or 64bit during the imaging. fogprep.exe will remove master HD id from registry so you don’t get black screen of death on the boot.

    try this.
    normal wipe you master image HD. Install win7 as normal just hit next. upload load image to FOG with image type:Single Partition (ntfs only, resizable) with host os:windows 7(5)

    deploy to host.
    normal wipe HD, deploy win7 to the new host.

    let me know this works or not.


  • ubuntu@ubuntu:~$ sudo fdisk -l

    Disk /dev/sda: 500.1 GB, 500107862016 bytes
    255 heads, 63 sectors/track, 60801 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x3fbf3665

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 41 329301 7 HPFS/NTFS
    /dev/sda2 42 60801 488054700 7 HPFS/NTFS

  • Developer

    please post fdisk -l output on that pc.

  • Coming back to you after several tests.
    My model has two partitions. 100MB system partition and the partition.
    I run FOGPrep.exe commandesbcdedit and 3.
    I prepare FOG putting Windows 7 on the PC and “single partition, resize” the image and this is the result:


  • Developer

    Can you post all the output from fdisk -l?

  • [QUOTE]FOG doesnt care if you do or dont have the 100MB boot partition for Windows 7. Either way will work as intended :)[/QUOTE]
    Even if using the “Single Partition (NTFS Only, Resizable)”?

  • [SIZE=5][FONT=arial][COLOR=#333333]This is the output of fdisk-l:[/COLOR][/FONT][/SIZE]
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes

  • Jian Zhang: I look at it and come back to you for the info.

    Blackout: What is the procedure? To the master, and before starting to cloneFogPrep.exe?

  • Developer

    FOG doesnt care if you do or dont have the 100MB boot partition for Windows 7. Either way will work as intended 🙂

  • Developer

    Can you clone same hardware with 32bit windows 7 or xp? Do you know is your HD has advanced format (4K sector format)? [url]http://en.wikipedia.org/wiki/Advanced_Format[/url]

    To find out sector format size.
    boot with Ubuntu live cd run command
    [B]fdisk -l[/B]

    look for

    [B]Sector size (logical/physical): [/B]
    [B]I/O size (minimum/optimal): [/B]

  • First of all, thank you for your feedback …
    Yes, I tested by running FogPrep.exe but this has not changed, the error after cloning was still there.
    I also read that it was necessary to delete the system partition of 100MB, but with our new PC, the UEFI adds an MSR partition?

  • Developer

    If you are running 0.30, you will need to run FOGPrep.exe before uploading the image, is that something that you did?

  • Developer

    What problems are you having?

    I can clone Windows 7 32bit. I wouldn’t think 64bit would be much of a problem?