FOG server - Fatal Error: Failed to mount NFS Volume



  • Hi guys and girls,
    lady’s and gentleman, [IMG]http://ubuntuforums.org/images/smilies/icon_smile.gif[/IMG]

    I have successfully installed Ubuntu desktop 10.04 LTS in a VMware ESX virtual machine. And then i installed latest FOG server on it. A view days ago. Also tested it and it works. Pulled and Deployed an image. Without sysprep. Just pull and push for the sake of testing. Which is good. [IMG]http://ubuntuforums.org/images/smilies/icon_smile.gif[/IMG]

    I have also another Windows File-Server. And a shared FogImages folder there that i mounted in Ubuntu so that i could use it for images i pull. But it gives me the following error since i (with my collegue) have setup to automatically mount the share on Ubuntu.
    Error “Fatal Error: Failed to mount NFS Volume.”

    My collegue is a littlebit more expirienced Linux than i am. So for him it was question of minutes which for me could be hours. So he fast fixed it here.

    What did we do:
    we added fogpw text tile to the /etc/ folder. And then added this line to fstab in /etc/:
    //FileserverIPADRESS/FogImages /media/fogimages cifs credentials=/etc/fogpw, defaults 0 0
    and then renamed the images folder on the root to images.old and made a symbolic link to the /media/fogimages. I also have copyed the dev folder and everything from images.old to images new. Which is on the share now. So i can go to images folder (symbolic link) on the root of Ubuntu server and i land in the Windows share.

    The share has the following perpisiions:
    Share rights - everyone full controll
    Security rights - Modify (for the user in fogpw file in the /etc/)

    When fog is pxe booting this is what it prints:
    Mounting File System … mount: FileserverIP:/images/dev failed, reason given by server: Permission denied.
    mount: mounting FileServerIP:/images/dev/ on /images failed: Bad file descript
    Done
    Checking Mounted Filesystem …
    An error has been detected!
    Fatal Error: Failed to mount NFS Volume.
    Computer will reboot in 1 minute.

    Any suggestions where to look further? Or some one having more experience can give an advice? [IMG]http://ubuntuforums.org/images/smilies/icon_smile.gif[/IMG]

    Will be much appreciated,
    Thanks in advance,
    Nikolai



  • It seems my old kk20 account was deleted for being a “spammer”. Great as I had quite a few fixes posted under that username (from when I installed fog) and had never spammed in my life… oh well.

    anyway I am revisiting this as I have moved my FOG to a new server and came up with the same error, luckily someone had “quoted” my original fix so I could look in the post_stage2.php file for changes I made (and I had commented them! yey!). Here is the change I made to post_stage2.php

    this line:

    [B]$dest = $noderoot . $_GET[“to”];[/B]

    I changed to

    [B] $dest = “/raid6/data/FOG/” . $_GET[“to”];[/B]

    It seemed that the $noderoot was somehow incorrect for me. No idea why as it was only the final FTP that failed for me. Anyway, after hard coding my FTP location (not ideal but I needed a quick fix rather than a debug) this works fine for me and has done for years.

    for information, /raid6/data/FOG is my listed NFS share in FOG (which also has FTP share enabled in openfiler). I have no idea why the $noderoot does not work yet everything else does. Anyway, that single change in post_stage2.php fixed my final FTP issue (so no more manual image moving necessary!)



  • Bumping this because I finally got that problem fixed. I added a storage node with the ip and mnt point of the NAS, and set that as the active and master storage node. Images create just fine.

    However, now I get “* unable to move /dev/macadress to /imagename” I can rename the image in dev and move it when in the dev file (sudo mv macaddress …/imagename) Which works, but I’m planning on running hundreds if not thousands of different images, I do not want to do this manually for each image.

    This error is the exact one listed here: [url]http://www.fogproject.org/wiki/index.php?title=FOGUserGuide#Separate_NFS_Server[/url] under KNOWN ISSUE.

    I have turned on the FTP service on my FreeNAS system, but there is no place for a username or password to be entered. I have both “Allow Root Login” and “Allow Anonymous Login” checked in the settings, the path set to the same place as the mount. I believe everything is set up correctly in there and I’m hoping someone with more knowledge of FOG and using FreeNAS with NFS can chime in on what I am overlooking or not understanding.



  • I will look into those again. I looked through them while doing this though. The permissions used from the first link are more inclusive than the permissions from the second link. I didn’t notice that before, but I tried adding those as well just now, and no change.

    Here is a text dump of what shows on the unit that I am trying to upload an image from.

    [CODE]* Send method…NFS

    • Preparing to send image file to server.
    • Mounting File System …mount: 192.168.15.72:/images/dev/
      failed, reason given by server: Permission denied
      mount: mounting 192.168.15.72:/images/dev on /images failed: Bad file descriptor
      Done
    • Checking Mounted File System…
      ##############################################################

    An error has been detected!

    ##############################################################

    Fatal Error: Failed to mount NFS Volume.

    ##############################################################

    Computer will reboot in 1 minute.

    ##############################################################[/CODE]

    Should be noted that 192.168.15.72 is my FOG server. 192.168.15.15 is my FreeNAS box with the storage and /image file. I know the store mounts correctly because I can see it in Ubuntu and I have full permissions to read/write/execute on it.





  • Bumping this thread because I have the same problem. mntcheck files are there, ubuntu system can see the mount and can write to/read from it.

    I’ve using a FreeNAS system with a NFS share, authorized network set to 192.168.16.0/24 (my local subnet). All directories box checked, mapall user set to root.

    When I try to pull an image, it does exactly what the OP says. Stuff about permissions. I’ve chmoded /images on the ubuntu box (mounted from my FreeNAS). Is it possible that I need to change the permissions on the FreeNAS system somewhere? I’m out of ideas and google hasn’t been of much help anymore for this roadblock.


  • Banned

    This post is deleted!


  • nevermind for future reference I inserted the following after line 78 of /var/www/fog/service/Post_Stage2.php

    $noderoot = ltrim($noderoot, “/mnt”);

    All working with openfiler now :)



  • [quote=“KK20, post: 3647, member: 1185”]As an addendum. Openfiler has a particular quirk. Openfiler lets you create a folder then assign a share to the folder. You get to mix and match from SMB,CIFS, NFS, FTS or RSYNC. I chose NFS and FTP for my FOG share. NFS maps this as /mnt/raid6/data/FOG/

    however. within FTP it is mapped to /raid6/data/FOG - i.e. the /mnt is dropped. In order to get the very last FTP copy portion to work (to avoid “unable to move” errors)I needed to edit :

    /var/www/fog/service/Post_Stage2.php

    and alter the $src and $dest portions slightly. Im sure there is a config area for this somewhere but I didnt have time to find them. I couldnt see one in the settings part of the UI.[/quote]

    Hi KK20, what changes did you do to the Post_Stage2.php? as I’m having the exact same problem with FOG and Openfiler?

    Many thanks,

    Stephen…



  • i had the same problem, turns out i just needed a .mntcheck file created in /images and /images/dev.
    [url]http://fogproject.org/wiki/index.php?title=Image_Upload:_Error_Checking_Mount[/url]
    ive mounted a 1TB drive to /images before installing fog, created the .mntcheck files, and it now works perfectly!


  • Banned

    This post is deleted!

  • Banned

    This post is deleted!


  • I was getting the OP’s error. When trying to mount the NFS it was failing. I noticed that it had the wrong IP address, it was that of the outside NAT card, no the internal LAN card (VM). After correcting the settings in the FOG server (Storage management, all stoage nodes, edit, IP Address) I was still seeing that incorrect IP address when booting a host. I tried rebooting the server thinking that something might not have applied correctly - no difference.

    Then I decided to try registering the host again through the boot menu. After that and setting up the image task it was able to start the task! I don’t know if the settings are actually stored on the host machine or if it’s just coded into the host configuration file, but I would suggest that to everyone having problems in this thread. Make your changes, re-register your client, and then see if it works for you.



  • [quote=“Inbroker, post: 1020, member: 398”]
    Don’t know why but my mind has stuck in the idea that the /images folder was some kind of a magical folder required by Fog. I just pointed the image directory to the NFS share and it worked fine.
    [/quote]

    So what EXACTLY did you put in there besides /images?
    You said you put in the image directory on the share? how? 192.168.1.xx:/images ???

    This may be the answer everyone is seeking.



  • Hey there,

    I am tinkering around with another problem. I am receiving also on one of the laptops the vbe_init () failed with -22 because it seems that the /sbin/v68d is missing.

    so I am wondering if this NFS permissions problem is not with the FOG Server, as we can create the NFS Share on a different Storage Solution and mount it, but more like the kernel file or image or config used in the /tftpboot/fog on the fogserver is the problem?

    cheers



  • on my machine (fresh install of ubuntu 10) fog is user 1001.
    I made sure the user fog had the same ID and pass on my NAS. (no success)



  • What user id does does the FOG client use when it attempts to mount the storage directory from the fog server?



  • This is actually the same problem I am having.

    NFS share on FreeNAS machine is exported, and i can mount it from the FOG Machine fine.
    I created a fog user on the FreeNAS machine with same password as fog user on FOG install.

    Created a user on FreeNAS (fog, same password as fog user on FOG machine)
    chown -R fog /mnt/mountPoint/NAS/images
    chmod 777 //mnt/mountPoint/NAS/images (for testing of course)

    on fog server mount the images directory as /NAS
    can created file, directory’s there no problem, as well as in /NAS/dev
    have .mntchek file created in both places (/NAS, /NAS/dev)
    when I log into the web interface, the storage node stats are correct.
    Tried setting IP in storage node to IP of FOG and also of NFS server (FreeNAS machine)
    Also tried changing the path to local path or NFS path (Fre.NAS.IP.ADDR:/mnt/mountPoint/NAS/images

    i still get permission denied when client boots up and tries to mount NFS share to upload image to.

    I also get " Does not support NFS Export" when running “exportfs -a”.

    Kyle



  • Bump… Still stumped on this…



  • Can anyone confirm the user that fog is mounting the NFS share with? is it fog? [B]Permission Denied.[/B]

    the clue is pretty clear:
    [B]Fatal Error: Failed to mount NFS Volume.[/B]

    Then when I setup my /etc/exports and run exportfs -a I get an error of

    [B]/images does not support NFS Export.[/B]

    So, far we have the facts:
    A: Permission Denied
    B: Failed to mount NFS Volume
    C: Does not support NFS Export

    still searching for a solution… am also about to try a few other things, will share if anything comes from it.


Log in to reply
 

364
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.