• Hi guys I am having trouble preforming a “Full Host Registration and Inventory” on a Dell Optiplex 7050. I though this was a Spanning Tree setting issue on the switch but this option seems to be enabled. Not sure why I’m having this issue. I can push an image to any other model computer just seems to be an issue with this model.

  • Senior Developer

    @msaglioc99 Just bumping this so we don’t loose track of it…

  • @sebastian-roth I haven’t forgotten about you guys! My floor in our building was flooded (hot water heater broke) so I’ve had to relocate a lot of equipment. As soon as our floor is repaired I will work on this because I do need to find a fix. This issue defiantly has something to do with the newer Cisco switches though. I can get you the model if you would like. Sorry for the delay!

  • Senior Developer

    @msaglioc99 Figured this one out? Would be great if you could tell us what exactly caused this issue. I am sure other people will find that helpful too!

  • @msaglioc99 Very strange. Definitely update us, but I’m glad you at least know what the problem is. 🙂

  • Still looking into the issue but it seems the newer CISCO Swtiches do not work properly with the FOG Server. I am trying to still find the difference between the older switches, and the newer ones and will let you know ASAP.

  • Senior Developer

    @msaglioc99 said in Dell Optiplex 7050's:

    This defiantly is a Network Infrastructure Issue so I am going to have to speak with my Network Administrator to see what the issue is.

    Great you figured this out now. So the issue has actually nothing mutch to do with the Dell Optiplex 7050 machines I guess. It’s just that the switch is not properly configured. I think you need to read up on the spanning tree protocol (STP) to understand what this is about. It it used to prevent from loops in a network. For example if you connect just two switches in a loop with two cables a broadcast packet (like an ARP request) will loop between those two switches forever! To prevent from such a situation STP was invented. The switches send specially crafted packets over the network to detect such loops. In case they see such a loop as I described one of the links will be temporarily deactivated. All fine. So now let’s get back to what might be wrong with PXE boot on such switches. STP needs some time to detect the network topology and figure if there are any loops. But clients want to just go off and PXE boot too early but will fail because the switches have not gathered all the information needed yet and block the communication yet. So there is one solution to this called RSTP (rapid spanning tree protocol) which does pretty much the same but takes a lot less of the initial time. The other thing you can do if your switch does not have RSTP is to configure the client port as “port fast”. This way the port is not considered as possible loop port and traffic will be forwarded early enough for PXE booting clients.

    The other thing that just came to my mind is EEE (ethernet energy efficiency). Some ethernet cards and switches support that feature to power down when there is no traffic going on. But some drivers are buggy and do not properly switch the ethernet card back to normal transfer mode.

    What else? Maybe auto-negotiation? 100MB/s or 1000 MB/s? We have seen issues with NICs that don’t do proper speed auto-negotiation and will therefore fail to get up a proper connection and PXE boot.

    That’s just a bunch of ideas that came to my mind. Ask your network team to see what could actually be causing this issue…

  • We do have a detailed Network Plan but I will report my findings when I fix the issue.

  • @msaglioc99 we really know to less about your network infrastructure, do you have a detailed network plan? 😄
    If your network admin is skilled enough i am sure he will see the issue. Please report if you finally solved it and tell us the solution.

  • Okay so I did myself a favor and moved one of the 7050’s to a different floor on a different V-Lan, and a Different Switch. This defiantly is a Network Infrastructure Issue so I am going to have to speak with my Network Administrator to see what the issue is. Is there anything I should have him specifically check? He did say Spanning Tree was already enabled. We will have to compare settings to the other floors V-Lan, and Switch Settings. Any ideas would be helpful though. Just to confirm the 7050 is registering, and imaging successfully on a different floor in my building.

  • I had my network administrator check if the spanning tree settings are on. He verified it is on and also said it is enabled by default on all of our new switches. Regarding the client port being set to “port fast” does this need to be changed on the computer itself or the switch? Is this regarding the Spanning Tree Setting?

  • Senior Developer

    @msaglioc99 said in Dell Optiplex 7050's:

    This is also using an un-managed switch and I verified the spanning tree setting is enable.

    Where exactly did you check that spanning tree is enabled? Cannot be on the un-managed switch. Make sure it is enabled but the client port is set to “port fast”.

  • I’ve been testing this on two different 7050’s one with the BIOS updated 1.5.2 and one on 1.4.4 I can pull a third machine in if you would like? I have a whole stock room filled with them.

  • @msaglioc99 Just to confirm, this is all 7050s and not just this one?

  • @sebastian-roth Okay so I’ve connected the Optiplex 7050 to a port I was able to successfully image a 7040 on using the same port, and patch cable. This is also using an un-managed switch and I verified the spanning tree setting is enable. I am still receiving the same result. Are there any settings I should be checking on the machine itself?

  • Senior Developer

    @msaglioc99 Ok, the pictures always show (in different situations) where it tries to communicate to the server. So I guess there is something wrong with the network - be it the NIC, the cable, the switch, Spanning Tree settings, Ethernet Energy Efficiency settings or maybe even a couple of things playing a role. So please try those steps:

    • connect that laptop to a different port on the switch where you know another machine registers fine from
    • borrow a dumb unmanaged mini switch from somewhere and connect the client to that instead of straight to the network
    • use new patch cables!

  • Here’s also another example of when I try to image a Optiplex 7050 at the end of registration if I want to image it now it asks me to enter my username and password for the FOG GUI. On the other machines it would usually show the username and keep the password secure (not showing the text) but as you can see here it writes in plan text and never officially registers the device just continues to let me write in plain text. There’s some kind of communication between the 7050’s and the FOG Server. They aren’t talking properly for some reason.

  • It’s very strange… I can’t figure out why I’m only having issues with this model computer…

  • As I said it is very random and I get a different error ever time only with the 7050’s though. I have on issues with other computer models. Here are some of the errors I am encountering.

    ![0_1506698591709_IMG_1368.jpg](Uploading 100%)
    ![0_1506698615428_IMG_1369.jpg](Uploading 100%)
    ![0_1506698634778_IMG_1437.jpg](Uploading 100%)