403 Forbidden error when trying to access x.x.x.x/dban

  • I have been following the steps listed on the wiki and also conferring with Tom on adding DBAN to the iPXE menu.

    The process right now:

    mkdir /iso
    mkdir /var/www/html/dban 
    # also did /var/www/dban from what the wiki said for Debian
    wget -O /iso/dban.iso http://downloads.sourceforge.net/project/dban/dban/dban-2.3.0/dban-2.3.0_i586.iso
    mount -t iso9660 -o loop /iso/dban.iso /var/www/html/dban

    In both places it will mount read only, but I keep getting 403 Forbidden errors from it for some reason when trying to navigate to x.x.x.x/ or x.x.x.x/dban

    So far we’ve tried

    chown -R www-data /var/www/html/dban /var/www/dban
    chmod -R 755 /var/www/html/dban /var/www/dban


    a2dissite 000-default

    That’s all I have at the moment. Tom was helping me, but I know he’s busy he doesn’t need me PMing him. 🙂

    Anything would be great!


  • @Sebastian-Roth That worked! Thanks so much!

    Can you explain more to me why I can’t browse to x.x.x.x/dban and see the about.txt?

  • @Sebastian-Roth Oops, forgot the first rule of FOG. List your version number. 🙂

    1.5.0 RC-3

    Looks like that let me download the about file, so it’s a step in the right direction!

    I will try following the rest of the guide and see if it’s all set.

  • Senior Developer

    @THEMCV Which version of FOG do you have? I can’t remember when exactly that was but at some point (introducing the FOG API) the apache virtual host config has changed a bit and rewriting was added. This is causing a bit of a headache sometimes. Try this:

    a2ensite 000-default
    service apache restart
    mkdir /var/www/dban
    mount -t iso9660 -o loop /iso/dban.iso /var/www/dban

    Now you should be able to access http://x.x.x.x/dban/about.txt in your browser. Note that you cannot get a directory listing (http://x.x.x.x/dban/) as this would forward the request… Not sure why you are seeing a HTTP 403. When I tested it the filesystem access rights were not an issue. But you could also mount like this just to make sure: mount -t iso9660 -o loop,uid=www-data,gid=www-data /iso/dban.iso /var/www/dban

    It has to be /var/www/dban not /var/www/html/dban - at least for newer FOG versions I am sure!