SOLVED PXE Boot fail with errors PXE-T01: File not found, PXE-E3B: TFTP Error - file not found

  • Server
    • FOG Version: 1.4.4
    • OS: Ubuntu Server 16.04.02 (no GUI)
    • Service Version: PXE Booting
    • OS: Virtualbox PXE Boot

    Hello. I can’t seem to get a computer to PXE boot from the FOG server (called fogpxe).
    I installed FOG and then followed these instructions:
    These let my virtual machine detect the pxe server and boot from it. Once I select boot from network, it says
    PXE-T01: File not found
    PXE-E3B: TFTP Error - file not found
    Here is a screenshot 0_1501450093207_1ee40a58-4a8d-444b-8f07-cab07ea6b260-image.png

    Contents of /etc/dnsmasq.d/lstp.conf is this:

    lewis@FOGPXE:/tftpboot$ cd /etc/dnsmasq.d
    lewis@FOGPXE:/etc/dnsmasq.d$ sudo nano ltsp.conf
    [sudo] password for lewis:
      GNU nano 2.5.3                                    File: ltsp.conf
    # Sample configuration for dnsmasq to function as a proxyDHCP server,
    # enabling LTSP clients to boot when an external, unmodifiable DHCP
    # server is present.
    # The main dnsmasq configuration is in /etc/dnsmasq.conf;
    # the contents of this script are added to the main configuration.
    # You may modify the file to suit your needs.
    # Don't function as a DNS server:
    # Log lots of extra information about DHCP transactions.
    # Dnsmasq can also function as a TFTP server. You may uninstall
    # tftpd-hpa if you like, and uncomment the next line:
    # enable-tftp
    # Set the root directory for files available via FTP.
    # The boot filename.
    # rootpath option, for NFS
    # kill multicast
    # Disable re-use of the DHCP servername and filename fields as extra
    # option space. That's to avoid confusing some old or broken DHCP clients.
    # PXE menu.  The first part is the text displayed to the user.  The second is the timeout, in seconds.
    pxe-prompt="Press F8 for boot menu", 3
    # The known types are x86PC, PC98, IA64_EFI, Alpha, Arc_x86,
    # Intel_Lean_Client, IA32_EFI, BC_EFI, Xscale_EFI and X86-64_EFI
    # This option is first and will be the default if there is no input from the user.
    pxe-service=X86PC, "Boot from network", pxelinux
    # A boot service type of 0 is special, and will abort the
    # net boot procedure and continue booting from local media.
    pxe-service=X86PC, "Boot from local hard disk", 0
    # If an integer boot service type, rather than a basename is given, then the
    # PXE client will search for a suitable boot service for that type on the
    # network. This search may be done by multicast or broadcast, or direct to a
    # server if its IP address is provided.
    # pxe-service=x86PC, "Install windows from RIS server", 1
    # This range(s) is for the public interface, where dnsmasq functions
    # as a proxy DHCP server providing boot information but no IP leases.
    # Any ip in the subnet will do, so you may just put your server NIC ip here.
    # Since dnsmasq is not providing true DHCP services, you do not want it
    # handing out IP addresses.  Just put your servers IP address for the interface
    # that is connected to the network on which the FOG clients exist.
    # If this setting is incorrect, the dnsmasq may not start, rendering
    # your proxyDHCP ineffective.
    # This range(s) is for the private network on 2-NIC servers,
    # where dnsmasq functions as a normal DHCP server, providing IP leases.
    # dhcp-range=,,8h
    # For static client IPs, and only for the private subnets,
    # you may put entries like this:
    # dhcp-host=00:20:e0:3b:13:af,,client111,infinite

    I noticed that in the ltsp.conf file, the client is told to find pxelinux.0. Listing the directory of the /etc/tftpboot shows that pxelinux.0 doesn’t exist.

    How can I get FOG to work? Sorry if this is is too much.

    Thank you,

  • WOuld you mind looking over: The article you referenced is for legacy FOG, which with the right changes can still work. This article is newer and more applicable to more modern versions of fog.

  • Just ask, one of the moderators or myself can do so.

  • @tom-elliott Sorry but how do i mark this as the answer?

  • Aha, thanks a lot. That worked.
    Kinda silly of me not to see that link at the top of the legacy article.

  • WOuld you mind looking over: The article you referenced is for legacy FOG, which with the right changes can still work. This article is newer and more applicable to more modern versions of fog.