SOLVED Failed to set disk guid (sgdisk-) (restoreUUIDInformation) error after deploying to Surface Pro 4

  • Server
    • FOG Version: 1.4.4 SVN 6077
    • OS: CentOS7
    • Service Version:
    • OS: Windows 10


    Just testing out deployments to a surface pro 4. I have captured a basic image from the Surface (just created a local user on the machine to get to desktop, no sysprep). When I deployed back to the surface all seemed OK until the end where I got the 'Failed to set disk guid (sgdisk -) (restoreUUIDInformation) error.

    My d1.original.uuids file for the image contains:

    /dev/nvme0n1 b1f3ace2-8663-4e88-98b9-018c60d0b6a3
    /dev/nvme0n1p1 1:FE2F-E040 1:addec0c6-0546-46f6-8789-1b9002a30019
    /dev/nvme0n1p3 3:4A44EC6844EC5869 3:365e62e4-e5e5-4408-bc88-26e9f291bd3f
    /dev/nvme0n1p4 4:0C42EEA242EE902E 4:453f2067-0e0b-4fd2-b61e-ff5026dce0a0

    Could you assist?

    Thanks guys,

  • Moderator

    @Brian-Hoehn From the postings of the other users it seems like the new init files Tom provided did help. So I suppose you see a different issue here. Please open a new thread and post all your details there - FOG version, OS version, picture of the error on screen, …

  • Has there been any progress on this? I have 2 new lenovo images, Thinkpad T750 and Yoga 370, I’m trying to make and errors out on nvme0n1 and doesn’t complete the job. I tried the init files posted above but that didn’t help. When I down the generic image it doesn’t have any problems downloading. It’s only with the images that I upload from them.
    It boots afterwards just fine but I the imaged machines fail it license windows, the source machine works fine.

  • I just want to give a big thanks to @Tom-Elliott for the help, I had the exact same error on a Lenovo stock image that just kept giving same error and restarting. This solution worked great, thanks!

  • @Tom-Elliott It did Tom, thank you.

  • @TomBagley You have the message, yes, but it’s a warning, not an error now. your task should complete successfully.

  • @Tom-Elliott Hi Tom do I need to capture a fresh image after running that? Re-imaged and got the same message.

  • this was brought to my attention a couple of days ago. I don’t know why it’s suddenly not working, but this error, itself, shouldn’t cause any problems.

    Please use:

    wget -O /var/www/fog/service/ipxe/init.xz
    wget -O /var/www/fog/service/ipxe/init_32.xz

  • @Quazz Hi Quazz, seems to I’ve just reset the surface and it’s gone through the process and come back to OOBE without a problem.

  • Moderator

    Does the recovery partition still work properly?

    I believe (but am hapilly corrected), the UUID is primarily important for specific setups (guessing stuff like RAID? LVM, maybe certain filesystems like btrfs), but shouldn’t matter too much for something like this.

  • @UniSuperBox Hmm that’s interesting. It boots absolutely fine, if I hadn’t caught the error message I’m not sure I would have known.

  • I just got the same error when restoring an image taken from a stock Lenovo image. It appears to fail on the last partition, which should be the recovery partition. The computer still boots without it.

    Maybe you could check to see if the computer still boots correctly with recovery broken?