SOLVED Active task still showing even when complete

  • I am playing with the snapins. I have successfully deployed the Microsoft Suite. I am now working on Adobe applications. I tried to upload the entire suite as one package but the snapin would get to 99%. The page would go to refresh and would says something about the server not responding. I am now working on just doing the individual programs. I have done Photoshop so far. It uploads. I push the snapin to my client.

    The issue is that the dashboard keeps saying I have one active task. I go to the machine and Photoshop is installed and runs just fine. Why is the task still showing as active in the dashboard?

  • Moderator

    @datastream said in Active task still showing even when complete:

    @george1421 At the end a window does pop up that says installation successful and it has an ok button that I have to click.

    Well that is / was it. If the application never quits then FOG (as well as other deployment tools like PDQ Deploy) rely on the installer exiting with a success code to consider the application installed. The -silent or -quiet (or any other number of switches which means a silent install) are typically required for this to be a success.

  • I think I got it. I needed to follow the instructions on this page and put --silent in the command.

  • @george1421 At the end a window does pop up that says installation successful and it has an ok button that I have to click.

  • Moderator

    @datastream So if you manually copy the snapin pack to the target computer and then run the installer as its called out in the snapin configuration does it run to completion without any prompting? Remember this has to be 100% hands off installation. I’m going to suspect there is a pop-up or a question along the way that is stopping silent installation.

  • Still having issues with this. I have just imaged a machine. The snapins for the group are illustrator and photoshop. The computer is still hung on illustrator and won’t move on to photoshop. I have opened illustrator just fine so I no it is complete.

  • @george1421 This did not end up fixing anything. I changed the number to reflect an hour. I pushed out a snapin for Dreamweaver and it is still spinning away even after it is installed on the client machine. I also tried uploading the full suite and it failed to upload.

    I went into the /var/log/fog directory and looked at fogsnapinrep.log but didn’t see anything relating to my issues.

  • Moderator

    @datastream It will address any issue where php is waiting on a socket response. That is a round about way to say… maybe/maybe not or it may address both.

  • @george1421 I saw that but wasn’t sure where to adjust. Will this fix the upload of the large snapin files or the constant active task?

  • Moderator

    @datastream Well that answers what might be going on. Any application taking longer than 30 + 2 seconds to install and the php wait, will timeout.

    What you need to do is find your longest install time and then adjust your php.ini parameter default_socket_timeout to exceed that value. Something in the 180 to 240 maybe to start.

  • @george1421 Attached is a screenshot of that error.
    0_1498849275584_Screenshot (4).png

  • Moderator

    @datastream and there is nothing in the apache error log?

    for rhel/centos /var/logs/httpd/error_log for ubuntu /var/logs/apache2/error.log (I think).

  • Yes. I’ve gotten the single adobe applications to upload as snapins. The issue is that while they seem to install just fine, but the task is still showing as active in the dashboard and not finishing. I installed the Microsoft suite yesterday and it worked just fine. Once it was done, the active task disappeared from the dashboard.

  • Moderator

    @datastream (let me preface this with I don’t use snapins for application deployment we use a different tool for that, so I may be off base a bit).

    Yeah for those really large applications you may be better off placing them on a network share and the just deploying a batch file that mounts the network share and launches the installer from there. That will eliminate the need to copy those huge packages around.

    Its still not clear (in my mind) if the issue is with the package, FOG, or something timing out. You say you can install other packages without issue?

  • The suite is not installing. It is failing to upload when adding the new snapin. I then just started doing the apps one at a time and those upload fine. I think it has something to do with the time to upload or size. The suite is about 20GB and each app is around 1-2GB. I changed max sizes in the php.ini and I changed ftp timeout in the settings of the dashboard.

    I just did Illustrator and it hangs as well. I canceled the active task for Photoshop because it completed. I started a new one for Illustrator. I just went and checked the computer it is installing to and Illustrator appears to be installed just fine. It is still showing as an active task in the dashboard though.

  • Moderator

    @datastream How long does it take to install the Adobe suite as compared to Microsoft? I have no basis for this, but I’m wondering if something is timing out because adobe suite takes so long to install??

    Can you also look at the tail of the apache error log to see if any error was trapped there?