SOLVED Cannot deploy UEFI base Windows 10 install.

  • Cannot deploy UEFI base Windows 10 install.

    Server --> FOG version: Running Version 1.3.5-RC-10
    SVN Revision: 6066

    Client --> ASUS AIO C240z running Windows 10
    I am unable to deploy a UEFI Windows 10 image correctly. I can capture the image and then deploy it, but when I boot the newly imaged Windows 10 PC I’m getting an error message as follows (blue screen):

    Your PC/Device needs to be repaired
    A required device isn’t connected or can’t be accessed.
    Error code: 0xc00000225
    You’ll need to user recovery tools.  If you don’t have any installation media (like a disc or USB device), contact your PC administrator or PC/Device manufacturer.

    With the proper Windows 10 Repair Disk I can set the bootloader to point to the right EFI partition with the following commands:
    Open Windows Command Prompt

    1. diskpart
    2. list volume
    3. select volume # (# is the volume number matching “EFI”)
    4. assign letter=Z
    5. exit
    6. bcdboot C:\Windows /s Z: /f UEFI
    7. system reboot

    How can this problem be fixed. If I image the workstation as RAW image everything is fine.

    Thank you.


  • @louis.tasse

    Problem solved! Thanks!


  • @louis.tasse Thank you prompt replies. I will update to the latest release and keep you posted.

    Wayne, you are right if I leave the newly imaged workstation into “Legacy Mode” the workstation cannot see any bootable device on the hard drive. When in “UEFI Mode”, the workstation will boot up accordingly but only if the captured image was done as “RAW”.


  • Moderator

    I agree upgrade off from 1.3.5.x There was a nasty resize bug that was addressed in 1.4.0rc1

  • Moderator

    Please update FOG to the latest version, this may be caused by resizing issues, which are fixed in 1.4

  • Sounds a bit like you have a UEFI image and are deploying it to machines that are in legacy mode or vice-versa.

    Also, we can’t help you troubleshoot much while you’re still on a release candidate - so many problems have been fixed since then. The latest stable fog release is 1.4.1, please update.