• Having issues with Fog and pxe

    Have build a new fog server on Unbutu Server 17.04.
    Installed from GitHub. When I network boot a laptop it gets to the load boot.php and two lines of dots and then tells me that there is not enough space. Ipxe.org/31062006

    I’ve reinstalled the server a few times. Disabled the firewall.

    Any help would be great.


  • Senior Developer

    In case anyone is running into this same iPXE error again. Please read this thread. Old initrd files (init.gz from October 2014 instead of current init.xz) were in place and caused the problem.

    Not sure if this was the case here to but I doubt that ubuntu server was the problem!!

  • Moderator

    @tri_94 So is this case solved?

  • Thanks for the reply
    Its Fog 1.4.0 - SVN 6069
    I’m using fog for DHCP
    Its a hp desktop DC7900 - This machine works fine on my old fog server no problems.

    I’ve just tried a new install again this time using the desktop version of Ubuntu rather then the server and it works fine.

    So it sounds Unbuntu server related


  • Moderator

    What version of fog are you installing?

    What precisely do you have configured in DHCP for options 66 {boot-server} and dhcp option 67 {boot-file}?

    What system is providing your dhcp services?

    What computer are you trying to pxe boot?

    Is that computer in uefi or bios (legacy) mode?

    A clear screen shot (taken with a mobile phone) of the error also helps us understand the context of the error.